Monthly Archive for September, 2012

Billings Pro Touch Server & Client Syncing Issues


Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method CodeColorerLoader::CallBeforeHighlightCodeBlock() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-includes/plugin.php on line 170

Strict Standards: Non-static method CodeColorer::GetInstance() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-content/plugins/codecolorer/codecolorer.php on line 218

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/iloveitaly/mabblog.com/blog/wp-content/plugins/codecolorer/codecolorer-core.php on line 53

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/iloveitaly/mabblog.com/blog/wp-content/plugins/codecolorer/codecolorer-core.php on line 54

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method CodeColorerLoader::CallAfterHighlightCodeBlock() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-includes/plugin.php on line 170

Strict Standards: Non-static method CodeColorer::GetInstance() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-content/plugins/codecolorer/codecolorer.php on line 226

Quick tip for anyone having issues with getting their iPhone’s Billings Pro app to sync with a local Billings Pro server:

I recently grabbed a Asus RT-N16 and flashed it with DD-WRT. It was working great until I was fiddling with some of the wireless settings and accidentally reset the router.

After reconfiguring the router, my iPhone with Billings Pro Touch would not sync with the local Billings Pro Server. For some reason it seemed that the network tab on the server admin GUI wasn’t picking up my lastest public IP and/or reporting it to the switchboard service correctly. To fix your reported public IP: log out of the switchboard, click advanced, manually set your public IP, and login to switchboard again.

However, my phone would still not connect to my local server. It seemed like it cached the old public IP and wouldn’t update its connection details. The iPhone UI is sparse and doesn’t include any way to manually update connection details. However if you navigate to Settings –> Server, click on your switchboard account, and navigate to password field the “done” button will appear in the iPhone UI. If you click done it seems to pull the updated switchboard login details and it should sync without a problem.

Not sure if this made a difference, but I manually setup port forwarding for 60525-60527 and 7113-7118.





Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method K2::init_scripts() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-includes/plugin.php on line 405

Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method K2::setup_rolling_archives() should not be called statically in /home/iloveitaly/mabblog.com/blog/wp-includes/plugin.php on line 405